پشتیبانی چگونگی فعال کردن ssl روی ساب دامین برای زنفورو

وطن وب هاست


soltane7posh

کاربر
درود من زنفوروم رو ساب دامین نصب هست الان اس اس ال گرفتم چجوری فعالش کنم ؟

واسه وردپرس و .. یه افزونه هست نصب میکنی خودش فعال میکنه رو وردپرس خواستم بدونم واسه زنفورو هم هست ؟
 

H4M3D

مدیر کل
.htaccess
کد:
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
<IfModule mod_rewrite.c>
    RewriteEngine On
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301]
</IfModule>
 

soltane7posh

کاربر
این htcc من اینجوریه نیاز هست یکی شما رو بزارم جایگزینش کنم یا کلا زیرش اضافه کنم

# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
RewriteEngine On

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

soltane7posh

کاربر
جایگزین هم کردم ولی خوب حالت معمولی باز میکنه میخوام وقتی حالت معمولی باز میکنه انجمن رو کسی خودکار خودش ریدایرکت کنه به https
 

H4M3D

مدیر کل
کد:
  RewriteCond %{SERVER_PORT} 80
   RewriteRule ^(.*)$ https://www.example.com/$1 [R,L]
 

halal314

کاربر
سلام
من کدهای بالا رو وارد کردم، اما سایت هم با www و هم بدون www باز میشه، چطور کاری کنیم که فقط با www باز بشه؟
 

halal314

کاربر
H halal314 , آموزش - استفاده از فایل .htaccess برای تغییر پیشوند www
سپاس از لطفتون ، اما من نمیدونم باید این کد رو در کجای کدهای بالا بزارم و احتمالا چیزی باید حذف بشه یا نه. میشه لطف کنید کدهای https رو با کدهای www ترکیب کنید و مجددا اینجا قرار بدید؟
 

H4M3D

مدیر کل
H halal314 , باید زیر RewriteEngine On اضافه کنید
 

halal314

کاربر
H4M3D H4M3D , سلام مجدد
سایت اصلی من وردپرس هست و سایت زنفورو روی یک پوشه (/portal) نصب هست، هرکاری میکنم ریدایرکت میشه به صفحه اصلی وردپرس. اگر ممکنه خودتون برام حلش کنید حق الزحمه هم خدمتتون تقدیم میکنم
 

H4M3D

مدیر کل
H halal314 , مشخصات هاست و پیام خصوصی کنید.
 

Mohammadreza_v

Good Boy
کاربر
سلام

من وقتی کدای بالا رو حتی تو فایل اچ تی اکسس کپی میکنم

وقتی انجمنم با https میخوام لود کنم یه صفحه دیگه میاد به اسم frox

لینک انجمنم اینه :

https://forum.ritm-music.ir

با https مشکل داره صفحه frox بالا میاد ولی در حالت عادی با http خود انجمن لود میشه

مشکل کجاست؟
 

majid_comp

مجید آقابیگلوئی
مدیر
سلام

من وقتی کدای بالا رو حتی تو فایل اچ تی اکسس کپی میکنم

وقتی انجمنم با https میخوام لود کنم یه صفحه دیگه میاد به اسم frox

لینک انجمنم اینه :

انجمن تفریحی و تخصصی ریتم موزیک

با https مشکل داره صفحه frox بالا میاد ولی در حالت عادی با http خود انجمن لود میشه

مشکل کجاست؟
سلام تست کردم مشکلی نداره با https بالا میاد
 
بالا